fbpx

Deprecated JavaScript globals

In WordPress 5.5 the global JavaScript objects listed below were removed without being deprecated. WordPress 5.5.1 adds a backfill for these globals so they no longer cause JavaScript errors. The following objects were removed:

adminCommentsL10n attachMediaBoxL10n authcheckL10n commentL10n commonL10n inlineEditL10n navMenuL10n postL10n plugininstallL10n privacyToolsL10n setPostThumbnailL10n tagsl10n tagsSuggestL10n userProfileL10n wp.themePluginEditor.l10n wp.updates.l10n wpColorPickerL10n wpPointerL10n wpWidgets.l10n

This means that referencing these objects would result in a JavaScript error and would thus halt JavaScript execution. Some of these objects were being used in very popular plugins & themes. @omarreiss and I researched where these were used. This Google sheet shows the impact.

If we only count plugins

This post was originally published on this site

GET UP TO $500K IN BUSINESS FUNDING

Pin It on Pinterest

Share This
Xiphos Web Marketing

FREE
VIEW